Masto.host - Masto.host Dashboard is back up – Incident details
Get updates
Email
RSS
Atom
Get updates
Dark mode
All systems operational
Masto.host Dashboard is back up
Resolved
Major outage
Started 3 months ago
May 24, 2026
Lasted about 1 hour
May 24, 2026
02
03
UTC
Affected
Masto.host Website
Major outage from 2:44 AM to 3:29 AM
Masto.host Dashboard
Major outage from 2:44 AM to 3:29 AM
Updates
Resolved
May 24, 2026 at 03
UTC
Resolved
May 24, 2026 at 03
UTC
Masto.host Dashboard is back up. This incident was automatically resolved by Instatus monitoring.
Investigating
May 24, 2026 at 02
UTC
Investigating
May 24, 2026 at 02
UTC
Masto.host Dashboard is down at the moment. This incident was automatically created by Instatus monitoring.
UTC
UTC
UTC
UTC
UTC